ATtiny workshop

Computational Craft Week 7
Fall 2014

Many thanks to the High Low Tech group for all their work with the ATtinies.



http://hlt.media.mit.edu/?p=1695
http://hlt.media.mit.edu/?p=1695

agenda

WHERE WE ARE GOING

What's on for today:

PART 1: Programming ATtinies
PART 2: Midterm concept shareout
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attiny

WHAT IS IT?

An ATtiny is a small, cheap ($2-3) microcontroller that is
amazing for running simple programs that you can program
with the Arduino (vs. an expensive propriety ISP)
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5 pins: 3 Analogin, 2 PWM

ATtiny 45 ATtiny 85
4 KB Flash 8 KB Flash
256 bytes RAM 512 bytes RAM

Smaller
programs

Can’t store as
much data

Arduino Uno
32 KB Flash
2 KB RAM

11 pins: 8 Analogin, 4 PWM

ATtiny 44 ATtiny 84
4 KB Flash 8 KB Flash
256 bytes RAM 512 bytes RAM



attiny

WHAT CAN YOU DO WITH THEM?

Functions supported in Arduino IDE:

pinMode()
digitalWrite()
digitalRead()
analogRead()
analogWrite()
shiftOut()

pulseln()

millis()

micros()

delay()
delayMicroseconds()
SoftwareSerial (has been updated in Arduino 1.0)



http://arduino.cc/en/Reference/PinMode
http://arduino.cc/en/Reference/PinMode
http://arduino.cc/en/Reference/DigitalWrite
http://arduino.cc/en/Reference/DigitalWrite
http://arduino.cc/en/Reference/DigitalRead
http://arduino.cc/en/Reference/DigitalRead
http://arduino.cc/en/Reference/AnalogRead
http://arduino.cc/en/Reference/AnalogRead
http://arduino.cc/en/Reference/AnalogWrite
http://arduino.cc/en/Reference/AnalogWrite
http://arduino.cc/en/Reference/ShiftOut
http://arduino.cc/en/Reference/ShiftOut
http://arduino.cc/en/Reference/PulseIn
http://arduino.cc/en/Reference/PulseIn
http://arduino.cc/en/Reference/Millis
http://arduino.cc/en/Reference/Millis
http://arduino.cc/en/Reference/Micros
http://arduino.cc/en/Reference/Micros
http://arduino.cc/en/Reference/Delay
http://arduino.cc/en/Reference/Delay
http://arduino.cc/en/Reference/DelayMicroseconds
http://arduino.cc/en/Reference/DelayMicroseconds
http://arduino.cc/en/Reference/SoftwareSerial
http://arduino.cc/en/Reference/SoftwareSerial

attiny

WHAT CAN YOU DO WITH THEM?

Sound

Capacitance

Servo

12C Communication (Wire library) - a
little unstable

REMEMBER: Libraries written for the 45/85 won’t work
for the 44/84.



http://www.kobakant.at/DIY/?p=3408
http://www.kobakant.at/DIY/?p=3408
http://hlt.media.mit.edu/?p=1653
http://hlt.media.mit.edu/?p=1653
https://github.com/fri000/Servo8Bit
https://github.com/fri000/Servo8Bit
http://arduino.cc/playground/Code/USIi2c
http://arduino.cc/playground/Code/USIi2c
http://arduino.cc/playground/Code/USIi2c
http://arduino.cc/playground/Code/USIi2c

overview

WHAT WE ARE GOING TO DO

Turn the Arduino into an “In System Programmer”
//This means we can program the ATtiny with it

//There are other types of ISPs that are also great - if you
want to work extensively with ATtinys, | suggest the
USBtinyISP from Adafruit

Program the ATtiny with the Arduino

//We can write code in the Arduino IDE and upload it to the
ATtiny through the Arduino.

//You can think of the Arduino as a translator.



materials

HARDWARE

Arduino Uno or Duemilanove (w/ an ATmega328, not an
older board with an ATmega168)

ATtiny45

a 10 uF capacitor
breadboard
jumper wires
LED

3 volt battery

alligator clips


http://arduino.cc/en/Main/ArduinoBoardDuemilanove
http://arduino.cc/en/Main/ArduinoBoardDuemilanove
http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=ATTINY45-20PU-ND
http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=ATTINY45-20PU-ND

materials

SOFTWARE

Arduino 1.0.5 (at least)
//This is important - previous versions were a tad buggy.

ATtiny core
//Alibrary



step



attiny core

LET’'S TAKE CARE OF THIS FIRST

Follow this link or go to the link | posted on the blog.
//This is important - previous versions were a tad buggy.


https://github.com/damellis/attiny/archive/master.zip
https://github.com/damellis/attiny/archive/master.zip

attiny core

LET’'S TAKE CARE OF THIS FIRST

Follow this link or go to the link | posted on the blog.
//This is important - previous versions were a tad buggy.

Find the Arduino folder in your computer.
//All of your sketches live here. Usually in “Documents.”


https://github.com/damellis/attiny/zipball/Arduino1
https://github.com/damellis/attiny/zipball/Arduino1

attiny core

LET’'S TAKE CARE OF THIS FIRST

Follow this link or go to the link | posted on the blog.
//This is important - previous versions were a tad buggy.

Find the Arduino folder in your computer.
//All of your sketches live here. Usually in “Documents.”

Create a new folder and name it hardware.
//The lower case is important!


https://github.com/damellis/attiny/zipball/Arduino1
https://github.com/damellis/attiny/zipball/Arduino1

attiny core

LET’'S TAKE CARE OF THIS FIRST

Unzip the file you just downloaded.



attiny core

LET’'S TAKE CARE OF THIS FIRST

Unzip the file you just downloaded.

You should see a folder called attiny that contains boards.txt
and a folder called variants.



attiny core

LET’'S TAKE CARE OF THIS FIRST

Unzip the file you just downloaded.

You should see a folder called attiny that contains boards.txt
and a folder called variants.

Drag the attiny folder into the hardware folder you just
created.



attiny core

LET’'S TAKE CARE OF THIS FIRST

Unzip the file you just downloaded.

You should see a folder called attiny that contains boards.txt
and a folder called variants.

Drag the attiny folder into the hardware folder you just
created.

If you had Arduino open, you must restart it.



attiny core

LET’'S TAKE CARE OF THIS FIRST

It should look like this:
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step 2



upload the sketch

MAKE THE ARDUINO AN ISP

Open Arduino and connect your Arduino to your computer.



upload the sketch

MAKE THE ARDUINO AN ISP

Open Arduino and connect your Arduino to your computer.

Go into Files > Examples > Arduino ISP.



upload the sketch

MAKE THE ARDUINO AN ISP

Open Arduino and connect your Arduino to your computer.

Go into Files > Examples > Arduino ISP.

Go into Tools > Boards > (whichever board you are using)
//You need to tell Arduino which board it is talking to.

//On another note, you should see a list of ATtiny boards to
choose from. Raise your hand if you do not see them.



upload the sketch

MAKE THE ARDUINO AN ISP

Open Arduino and connect your Arduino to your computer.

Go into Files > Examples > Arduino ISP.

Go into Tools > Boards > (whichever board you are using)
//You need to tell Arduino which board it is talking to.

//On another note, you should see a list of ATtiny boards to
choose from. Raise your hand if you do not see them.

Upload the sketch to Arduino.



step 3



the circuit

CONNECTING THE ATTINY TO THE ARDUINO

This is where you might make a mistake (if at all :)
//1t can be difficult to see which wires go where.

Pay close attention to where you are putting your wires.
//We're gonna take this step by step.

First off, unplug your Arduino from your computer.
//We don’t want a power supply right now.



Connecta 10 uF
electrolytic capacitor
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Connectone
side of your
breadboard to
Power.
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breadboarding prep

CONNECTING THE ATTINY TO THE ARDUINO

Insert the ATtiny into

your breadboard,
over the bridge in the D
middle.
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Notice the circle on this

circuit?




hookin it up

CONNECTING THE ATTINY TO THE ARDUINO

This is how you know which side is which.

ATtiny45 / ATtiny85
)
\—
Reset []1 8 VCC (+)
(Analog Input 3) Pin3 [ ]2 7 Pin 2 (Analog Input 1, SCK)
(Analog Input2) Pin4 [ |3 6| Pin1(PWM, MISO)
(=) GND L|4 S Pin 0 (PWM, AREF, MOSI)



hookin it up: attiny45/85

CONNECTING THE ATTINY TO THE ARDUINO

ATtiny45 / ATtiny85

Power
Reset |

(Analog Input 3) Pin 3 |
(Analog Input 2) Pin 4

VCC (+)

Pin 2 (Analog Input 1, SCK)
Pin 1 (PWM, MISO)

Pin 0 (PWM, AREF, MOSI)

Ground



& & & 0 ® & & & =

& & & e & & & e »

& & & 0

8 & 0

=
o
u
E
£

e ® & 0 0
& & &
e & & & 2

. & & 9

3 2
11

- L

™
m RX

9
-
=
a

==

a

o

W w.arduino.cc
ANALOG IN

, PO\ 'ER
A5V Gt | Vin

0

1

8 765 4321
DIGITAL
= =

0
s EE
=

2 3 45




Arduino {UNQ:emon @

b
oF:

]

1

W w.arduino.cc

ANALOG IN

012345

PO\ 'ER
5V Gr ' Vin

J
>
™

Ground

*
. 0
* L
L ) L
> ® » » LR
" 0 0 L
* * 9
e " 0 0 . »
® * » LR
e " 0 0 . »
® * » » LR
e " 0 0 . »
* * 9
e * . »
* 0 . »
PR -
B e
* . »
. " » . »
* * » »
e 0 . »
* LR
e * @ . »
* * »
e o * @ . »
9
e o » @ . »
» . »
e o * @ . »
» . »
e o * @ e @
L I
2 & » »



hookin It up: attiny45/85

CONNECTING THE ATTINY TO THE ARDUINO

ATtiny45 / ATtiny85 PI n 13

(Analog Input 3) Pin 3 [
(Analog Input 2) Pin 4 [C
(-) GND [

S~ O -

/

O o N ®

] VCC (+
In 2 (Analog Input 1, SCK)

PS> Pin 12

Pin 11
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pinout: attiny44/84

FOR REFERENCE
ATtiny44-84

(+) VCC

Pin 10

Pin 9

Reset

(PWM) Pin 8

(PWM, Analog Input 7) Pin 7

(MOSI, PWM, Analog Input 6) Pin 6

NO O A O N -

14

13

12 [

11

10

9

of

ATtiny44 / ATtiny84

GND (=)

Pin 0 (Analog Input 0, AREF)

Pin 1 (Analog Input 1)

Pin 2 (Analog Input 2)

Pin 3 (Analog Input 3)

Pin 4 (Analog Input 4, SCK)

Pin 5 (Analog Input 5, PWM, MISO)



step 4



open the sketch

PROGRAMMING THE ATTINY

Go into Files > Examples > .01Basics > Blink.

Changeintled=13tointled = 3.

B1ink

Tums on an LED on for one sacond, then off for one sacond, repeqtedly.

This exanple code is in the public domain

RlED connected on most Arduino boards.

'/ give 1L a none?

int led = 13;

J-. = Atine runs once vhen you press reset:
void ',rhl['v() {
/ intticliize the I.X'.;'.'.‘J. pin ¢ an output.
pirttoce(led, OUTPUT);
}

// the loop routine runs over and over ogain forever:
vold loop() {
digitelWrite(led, HIGH); // turn the LED on (MIGH iz the woltoge level)
‘.r‘lﬂ(’,“); /7 wait for a second
digitclvrite(led, LOW); /7 turn the LED off by maxking the voltags LOV
deloy{1080); // wait for a second

¥

-~ AV



pick the right board

PROGRAMMING THE ATTINY

Go into Tools > Boards > ATtiny45 (Internal 1IMHz Clock) or
ATtiny45 (Internal TMHz Clock)
Archive Sketch

i Fix Encoding & Reload

gint  Serial Monitor ¢ %M
win  ArduBlock

. Board b ATtiny45 (internal 1 MHz clock)

Auto Format

‘15 Serial Port »  ATtiny45 (internal 8 MHz clock)
ATtiny45 (external 20 MHz clock)
s pin  Programmer ¥ ATtiny85 (internal 1 MHz clock)

s giw  Burn Bootloader ATtiny85 (internal 8 MHz clock)

n T —{ i
t led w133 ATtiny85 (external 20 MHz clock)

/ the setup routine runs once when vou ¢ ATtiny44 (internal 1 MHz clock)

0id ;c:upsl)lm R ol ATtiny44 (internal 8 MHz clock)
/7 1NSLc o The Glc il J1N Qs an ol .
virHode(led, OUTPUTY; ATtiny44 (external 20 MHz clock)

ATtiny84 (internal 1 MHz clock)
ATtiny84 (internal 8 MHz clock)



assign the programmer

PROGRAMMING THE ATTINY

Go into Tools > Programmer > Arduino as ISP

Auto Format

Archive Sketch

Fix Encoding & Reload
Blinl  Serial Monitor O #¥M

51 ArduBlock

Turere )} Of
Board >

‘15 Serial Port p .
ol Programmer r

. -iw  Burn Bootloader

lnt lw’m—1

'/ the setup routine runz once when you g

void setup()

T Tor one second, repeqtedly.

AVR ISP

AVRISP mkll
USBtinyISP

USBasp

Parallel Programmer

/7 initialize the digital pin as an o ,/ Arduino as ISP

pinMode(led, OUTPUT);
H




upload the sketch

PROGRAMMING THE ATTINY

Go into File > Upload using programmer

New #EN

Open... #0

Sketchbook P

Examples B

Close BW

Save #S

Save As... IS T PNA:EecoNay: Tepec
Upload ®¥U

Page Setup 0RP Joores.

Print #P

/ the setup routine runs once vhen you press reset:

oid setup() ﬂ

/7 initialize the digital pin as on output.
pintode(led, OUTPUT);



upload the sketch

PROGRAMMING THE ATTINY

This is OK:




Make light!

PROGRAMMING THE ATTINY

Insert an LED on pin 3 for the ATtiny45/85



e TX
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debug time



next steps

TRY SOMETHING ELSE!

Take it off the Arduino and connectit to a 3 volt.
//One more reason why the ATtiny is AWESOME.

Try to make a light (or two!) fade.
//Using PWM

Try this capacitance sketch
//http://hlt.media.mit.edu/?p=1653

A note on sound...


http://hlt.media.mit.edu/?p=1653
http://hlt.media.mit.edu/?p=1653

BREAK!

[then midterm sharings]



hookin it up: attiny44/84

CONNECTING THE ATTINY TO THE ARDUINO

Power W-M\ e / Ground
+) VCC [ 14 [J GND (-)

4 e
Pin10 []2 13
Pin9 |3 12
Reset [| 4 1
(PWM) Pin8 []5 10
(PWM, Analog Input 7) Pin 7 [] 6 9
(MOSI, PWM, Analog Input 6) Pin6 [|7 8

] Pin 0 (Analog Input 0, AREF)

] Pin 1 (Analog Input 1)

] Pin 2 (Analog Input 2)

] Pin 3 (Analog Input 3)

] Pin 4 (Analog Input 4, SCK)

] Pin 5 (Analog Input 5, PWM, MISO)
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hookin it up: attiny44/84

CONNECTING THE ATTINY TO THE ARDUINO

ATtiny44-84 ATtiny44 / ATtiny84
° U °
UL (+) VCC [ 1 14 [ GND () PIn13
Pin10 []2 13 [JJ Pin 0 (Analog Input 0,
n9 []3 12 i
ResetY 4 11 Pin12
(PWM) Pin8 []5 10
(PWM, Analog Input 7) Pin 7 [ 6 9
(MOSI, PWM, Analog Input 6) Pin6 [ |7 8 in 5 (Analog Input 5, PWM, MISO)

Pin 11
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